Uploaded image for project: 'SmartSprites'
  1. SmartSprites
  2. SMARTSPRITES-75

Sprites that uses images from different directory levels don't work

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 0.2.6
    • Fix Version/s: 0.2.7
    • Labels:
      None

      Description

      Assume we define the sprites as follow:
      ------------------------------------------
      /assets/css/library/mystyle1.css (...background-image: url(../../img/icon1.png); /** sprite-ref: iconSprite; */...)
      /assets/css/mystyle2.css (...background-image: url(../img/icon2.png); /** sprite-ref: iconSprite; */...)
      /assets/img/icon1.png
      /assets/img/icon2.png

      /** sprite: iconSprite; sprite-image: url('../../img/bg_sprite_icons.png'); sprite-layout: vertical */

      The resulting sprites and css will be:
      ------------------------------------------
      /assets/css/library/mystyle1.css (...background-image: url('../../img/bg_sprite_icons.png');...)
      /assets/css/mystyle2.css (...background-image: url('../../img/bg_sprite_icons.png');...)

      Notice that mystyle2.css is referring to the generated sprites ("../../img/bg_sprite_icons.png") now, but the correct path should be ("../img/bg_sprite_icons.png") instead.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                stachoo Stanisław Osiński
                Reporter:
                davcai David Cai
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: