SmartSprites
  1. SmartSprites
  2. SMARTSPRITES-49

Publish SmartSprites JAR in a Maven2 repository

    Details

    • Type: Task Task
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.2.5
    • Labels:
      None

      Description

      This should be initially available at: http://download.csssprites.org/maven2

        Activity

        Ibrahim Chaehoi added a comment -

        Hello,

        I've attached a pom.xml file, which I'm using to integrate smartsprites in my maven project.
        I hope that it can help.

        Cheers,
        Ibrahim

        Stanisław Osiński added a comment -

        Hi Ibrahim,

        I've (finally! ) set up automated building of SmartSprites Maven2 artifacts. Currently, the latest trunk version (0.2.5-dev) is available from:

        http://download.csssprites.org/maven2/

        All future stable and development releases will also be available from there.

        Please let me know if you have any problems using the artifacts.

        Cheers,

        S.

        Ibrahim Chaehoi added a comment -

        Hi Staszek,

        Thanks
        I've been able to retrieve the jar from your maven repository.
        It works like a charm

        There is only one thing which will be great to have, is to publish also the source of the project on your maven repository. So we will be able to retrieve it with the jar.
        Do you think that it's feasible?

        Thanks again

        Cheers,
        Ibrahim

        Stanisław Osiński added a comment -

        Hmmm – is there any convention for the sources jar? I've published this as:

        http://download.smartsprites.osinski.name/maven2/org/carrot2/smartsprites/0.2.5-dev/smartsprites-0.2.5-dev-sources.jar

        Cheers,

        S.

        Ibrahim Chaehoi added a comment -

        Hi,

        The name of the sources jar seems correct, but I'm not able to retrieve it using maven.
        It's strange...

        I will try to see why I'm not able to retrieve it.
        I will let you know if I find something.

        Cheers,
        Ibrahim

        Ibrahim Chaehoi added a comment -

        Hi Staszek,

        Sorry for my late reply.
        In fact, all is working properly.
        It was a misconfiguration on my side.

        As we are planning to release Jawr, I would like to know when do you think that you will be able to release the version 2.5.

        Cheers,
        Ibrahim

        Stanisław Osiński added a comment -

        Hi Ibrahim,

        I'm glad it works for you now.

        When it comes to the 0.2.5 release, there are two unresolved issues. If I don't get any extra comments on SMARTSPRITES-55, I'll have to resolve it as "Cannot reproduce", but I'd still need to take a look at SMARTSPRITES-53. I won't have much time until the 2rd of December, but I should be able make a release soon after that date. Does Jawr have the release date set yet?

        Cheers,

        Staszek

        Ibrahim Chaehoi added a comment -

        Hi Staszek,

        I think that we will release the new version of Jawr for the 2nd or 3rd week of december around the 10th to 14th december.
        It will be fine for us if you release smartsprites a little bit before.

        In any case, thanks for all.

        Cheers,
        Ibrahim

        Ibrahim Chaehoi added a comment -

        Hi Staszek,

        We have released Jawr, which now contains the integration with smartsprites.
        Thank you. Without your work, this release would have missed a really cool feature

        Cheers,
        Ibrahim


          People

          • Assignee:
            Stanisław Osiński
            Reporter:
            Stanisław Osiński
          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 2h
              2h
              Remaining:
              Remaining Estimate - 0h
              0h
              Logged:
              Time Spent - 1.75h Time Not Required
              1.75h

                Development